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O V E R V I E W  

 
The enterprise edition is introduced in release 5. The main advantage is the 
capability to have remote access and multiple client access. The following 
figure shows a BroadcastByPhone autodialer running as a client and 
controlling Voicent Gateways at different locations from which the actual 
phone calls are made. BroadcastByPhone can automatically dispatch phone 
calls based on area code preferences set on each gateway. 
 
 

BroadcastByPhone   
Internet 

 
Phone Lines 
Area Code 2  

LAN 

 

Phone Lines 
Area Code 3 

Phone Lines 
Area Code 1 

 
 
 
Since Voicent products employ the same technology used on the Internet, 
they offer the ultimate scalability and flexibility. For example, a school 
district can deploy the system on each campus; each system can be used for 
phone calls about local issues, and all the systems can be used by the district 
office for district-wide phone calls. Voicent Enterprise Edition offers the 
ultimate solution for large organizations, such as political parties, nation-wide 
churches, and large businesses. 
 
Even for individual users, the ability to run Voicent applications from a 
remote computer offers unsurpassed flexibility. As long as you have internet 
access, you can start a broadcast while away from the office or while you are 
traveling in a different country. You can even partner with your friends to 
share each other’s system. 
 

- 2 - 



VOICENT COMMUNICATIONS INC 

I N S T A L L I N G  A N D  S E T T I N G  U P  T H E  S E R V E R  

 
Please follow the Quick Start Guide to install the server software. The server 
software installation is the same as the desktop (Standard or Professional 
Edition) software installation.  

Please note that the installed software 
is exactly the same, regardless of 
whether it is a shareware, standard, 
professional or enterprise edition. The 
difference is in the license key that is 
installed. For example, without an 
enterprise edition license, all remote 
access features are disabled. 

Once the software is working on the 
server machine, please setup the 
gateway password (optional) and area 
code preferences. Click on the 
Gateway icon to invoke the gateway 
main window, select Setup > 
Options… from the main menu, then 
select the Control panel. 

 

A C C E S S I N G  T H E  S E R V E R  F R O M  L A N  

 
Voicent Gateway (the server) is actually the software that makes telephone 
calls. All Voicent applications, such as BroadcastByPhone, AutoReminder, and 
AgentDialer are clients of the gateway. To make a call, they simply submit a 
call request to the gateway, and query the gateway for call status after the 
call is made. Technically, the communication protocol between the client and 
the gateway is HTTP, the same protocol used by the Internet.  
 
Voicent Gateway is listening on port 8155. 
 
To make sure you can access the server (Voicent Gateway), you should use a 
regular browser to test it first. You can test it on the same computer this is 
running the gateway. Please type in the following in the browser address bar: 
 
http://localhost:8155/appclient.jsp?action=ping 
 

The server should return [OK] as shown below. 
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If testing from a computer on the same local area network (LAN), replace the 
word “localhost” with the server computer name or its IP address. You can 
find the host name and IP address from the gateway main window. 

If you experience failure, please verify that the gateway is started.  

The next most likely cause of failures is your anti-virus or firewall software. 
They might block Voicent 
Gateway from listening on port 
8155.  

Windows XP and later operating 
systems come with a built-in 
firewall. Please make sure 
accessing Voicent Gateway is 
enabled. From Windows Control 
Panel, you can access Windows 
firewall, click on the Advanced 
tab, then choose Local Area 
Connection, click on the 
Settings… button, then click the 
Add… button. Enter the service 
settings, and then click OK. 

 

Your computer may have other anti-virus or firewall software installed. 
Please check the vendors manual (Norton, McAfee, etc). One way to test it 
out is to disable or uninstall the anti-virus software, then install it back when 
everything works. You can also take a look at Help > Troubleshooting… from 
the program main menu, then take a look at the topic labeled “Voicent 
Gateway is not running”. 
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ACCESSING THE SERVER FROM THE INTERNET 

It is somewhat complicated to access Voicent server software from the 
Internet. Most large organizations set up sophisticated firewall systems for 
security reasons. You should contact your IT organization for allowing access 
from the outside. Basically you need to have your IT organization allow 
access to the required port on your server machine. 

Voicent Gateway uses TCP port 8155. For AgentDialer, the gateway uses an 
additional TCP port 8165 for remote agent login. If you use SIP, AgentDialer 
also uses UDP port 8455 for line 1 phone audio, 8456 for line 2, and so on. 
For AutoReminder, it uses the port number you set from View > Setup 
Client Server… dialog window. 

To setup remote access from the Internet usually involves configuring your 
firewall hardware or software. It does not involve configuring Voicent 
software. Voicent cannot and will not provide support regarding issues 
related to your ISP or hardware providers. Please contact your ISP or your 
router/firewall provider for these issues. Another place to get help is your 
local computer service company that provides onsite service. 

The following material is provided only as a general guide for setting up 
remote access and configuring your firewall. It provides some basic 
information, primarily relating to home networking or small office 
networking. You can search the Internet for more information regarding this. 

Computer IP address 

The IP address is an address that uniquely identifies a computer on a 
computer network. The format of an IP address is a 32-bit numeric address 
written as four numbers separated by periods. Each number can be zero to 
255. For example, 192.168.0.100 could be an IP address. The main window 
of Voicent Gateway shows the server computer name and its IP address. 

Static IP address and dynamic IP address 

Your ISP assigns an IP address to your computer when it connects to the 
network. If your ISP always assigns the same IP address, then you have a 
static IP address. If your computer IP address changes every time you 
connect, you have a dynamic IP address. It is much easier to have a static IP 
address for remote access. Please contact your ISP for static IP service. 

Router 

A router is a device that connects and forwards data among computer 
networks. Your broadband access device, such as DSL modem or cable 
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modem, usually comes with a built-in router and firewall. Your home network 
connects to the Internet through that router device. 

A router normally contains two IP addresses, one for the outside network and 
one for the inside network. The outside IP address is usually called Internet 
or WAN address, while the inside address is called LAN address. The Internet 
address is usually assigned to you by your ISP and LAN address by the 
router. 

Firewall 

A firewall is a device used to prevent unauthorized access to or from a 
private network. Firewalls can be implemented in both hardware and 
software, or a combination of both. The following is a typical home 
networking connection diagram. 
 

 

 WAN address
 Internet LAN address 

 

Router/firewall DSL modem

To allow remote access from the Internet, you normally have to configure 
your router/firewall to enable it. Most firewalls block all access from the 
Internet by default. The following example is for a Linksys router/firewall. 

The example assumes that Voicent Gateway is running on a server with IP 
address 192.168.15.10, and the Internet address for the router is 
64.233.187.99. 

Linksys Example 

1. Login to the Linksys router/firewall administration home page. Please 
check your Linksys User Manual on how to do this. Please also note 
that your Linksys administration page might be different. 

2. You can discover your Internet IP address by selecting Status > 
Router. In our example, 64.233.187.99 should be listed. Write down 
the IP address as you’ll need it for remote access. 

3. Click on Applications/Gaming on the top, and then select Port Range 
Forwarding. In the diagram below, the application name is Gateway, 
the port is 8155 and 8165, and the protocol is TCP. The server that is 
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running Voicent Gateway has an IP address of 192.168.0.10. Click the 
Save Settings button. 
 

 

What this configuration tells the router to do is the following: When a remote 
computer tries to access the gateway on port 8155 or 8165, the router 
should forward the request to the computer with the IP address 
192.168.15.10. The remote computer cannot directly access the gateway 
computer directly through 192.168.15.10 because it is a local address only 
known to the router. The remote computer must use the Internet/WAN 
address. If you use SIP line and AgentDialer RemoteAgent, you need to open 
up UDP port 8455 for line 1, 8456 for line 2, and so on. 

You can test the settings from a remote computer by typing in the following 
in the browser address bar. Please replace the IP address 64.233.187.99 
with your actual Internet IP address. 

http:// 64.233.187.99:8155/appclient.jsp?action=ping 

You should see [OK] in the browser window if your setting is working. 

If not, please check your router/firewall manual or contact your ISP or 
router/firewall company for help. Voicent support does not know what 
specific configurations are required for your particular setup environment. 
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I N S T A L L I N G  A N D  S E T T I N G  U P  C L I E N T  

 
To install the client software, start by running the installation software 
downloaded from the internet or from the CD. Click the Client Applications 
button, and then follow the on screen instructions. 

The following sections show setup steps specific to a product. 

 

B R O A D C A S T B Y P H O N E  E N T E R P R I S E  E D I T I O N  

 
Setting up the Server 

Voicent Gateway server set up is described in previous sections. 

Setting up the Client 

To access a remote Voicent Gateway, select Broadcast > Broadcast 
Hosts… from the program main menu. Click Add button to add a new host. 
As we described before, Voicent Gateway is listening on port 8155. If you try 
to access a remote gateway from the Internet, you must configure the 
router/firewall on the gateway location to allow port 8155 access. Please 
refer to the previous section for details. 
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A U T O R E M I N D E R  E N T E R P R I S E  E D I T I O N  

 
The AutoReminder program is a client of Voicent Gateway for making phone 
calls. However, the program is itself a server for other AutoReminder 
programs. This is because all appointment information is managed by 
AutoReminder, not the gateway. In order to share appointment information 
among several AutoReminder programs, one program must serve as a 
server. The following is a typical setting. 

 

The AutoReminder client does not connect to the gateway directly. It only 
connects to the AutoReminder 
server, which must connect to a 
locally run Voicent Gateway. Any 
change on the client will be 
reflected on the server and vice 
versa. 

Setting up the Server 

Select View > Setup Client 
Server… from the main menu; 
then select Run on Computer 
where Voicent Gateway is 
installed. Also select Allow web 
access and Remote Client 
Access. Choose a listening port 
number and access password. 

Phone lines 

 

Appointment 
information kept on 
server 

AutoReminder Client 

AutoReminder Server 
and Geteway AutoReminder Client 
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If you want to enable remote access form the Internet, you need to configure 
your router/firewall to allow access to the port number you specified. There 
is no need to open the Gateway port (8155 and 8165). 

Setting up the Client 

You can first test whether you can access the AutoReminder server using a 
web browser. Simply type in the following in your browser address bar: 

http://server_hostname_or_ipaddress:port_number 

Please replace server_hostname_or_ipaddress with the real name, and 
port_number with the one you set as the Listening port on the server. 

To setup the client, select View > Setup Client Server… from the program 
main menu, choose Run as remote client, then specify the server name or 
IP address, the listening port, and the server access password. Click OK. Now 
you should be able to connect to the server next time you run AutoReminder. 

If it does not work, please make sure AutoReminder Server is currently 
running. If it is running, then try to access it from the same machine using a 
web browser. Try it with the same address listed above. Replace 
server_hostname_or_ipaddress with localhost. If you can access it from a 
web browser on a local machine but not on a remote machine, you have to 
take a look at your router/firewall settings. Please refer to a previous section 
for details. 

Test Client Server Settings 

You can add an appointment from the client program. Make sure the 
appointment is added to both the client AutoReminder and server 
AutoReminder.  

 

A G E N T D I A L E R  E N T E R P R I S E  E D I T I O N  

 
When an agent is working on a computer other than the computer on which 
Voicent Gateway is running, the agent must login to the gateway using the 
Voicent RemoteAgent program. When a call is answered by a live human, an 
alert window will pop up on the agent’s computer. The alert window will 
display the gateway host name and the line number, it will also display the 
current call information, such as the callee’s name and phone number. 

It is strongly recommend that you use SIP or Skype instead of voice modems 
for AgentDialer. 
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Setup RemoteAgent 

On each agent’s computer, you have to install the Voicent RemoteAgent 
Program. The program can be installed from the installation package, select 
Enterprise Edition Client Applications from the dialog window to 
continue; then choose the RemoteAgent program to install. 

The RemoteAgent program 
simply allows an agent to logon 
and/or logoff one or more 
Voicent Gateway programs. 
Once logged on, the agent 
computer will receive live 
human pickup alert popup 
windows.  

Click on the button labeled 
Hosts… to add, remove, and 
connect to Voicent Gateways. 
The gateway listens on port 
8155 for the initial connection, 
and listens on port 8165 for 
agent login, logout, and alert. If you use SIP line, it also communicates with 
Agent on UDP port 8455 for phone audio on line 1, and 8456 for line 2 and so 
on. 

You can also take a look at the document labeled Predictive Dialer and 
Remote Agent Setup Guide” from the program Help menu.  

 
 
 

U S E F U L  R E S O U R C E S  

 

More information can be accessed from Voicent’s website. 

For more product info: http://www.voicent.com/support. 
For product purchase: http://www.voicent.com/store. 
For developer info: http://www.voicent.com/devnet 

 
 
 
 
 
Copyright: 
 
This document contains proprietary information protected by copyright, and this Enterprise Edition Setup 
Guide and all the accompanying hardware, software, and documentation are copyrighted. 
Copyrighted 2003 - 2008. Voicent Communications, Inc. All rights reserved. 
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