TABLE OF CONTENT

I. Overview
II. Install and Setup Server
III. Access Server from LAN
IV. Access Server from the Internet
V. Install and Setup Client
VI. AutoReminder Enterprise Edition
VII. BroadcastByPhone Enterprise Edition
VIII. AgentDialer Enterprise Edition
IX. Useful Resources
Enterprise edition is introduced in release 5. The main advantage is the ability to have remote access and multiple client access. The following figure shows a BroadcastByPhone autodialer is running as a client and controlling Voicent Gateways on different locations, where the actual phone calls are made. BroadcastByPhone can automatically dispatch phone calls based on area code preferences set on each Gateway.

Since Voicent products employ the same technology used on the Internet, they offer the ultimate scalability and flexibility. For example, a school district can deploy the system on each campus; each system can be used for phone calls about local issues, and all the systems can be used by the district office for district-wide phone calls. Voicent Enterprise Edition offers the ultimate solution for large organizations, such as political parties, nation-wide churches, and large businesses.

Even for individual users, the ability to run Voicent applications from a remote computer offers unsurpassed flexibility. As long as you have internet access, you can start your broadcast away from office or while you are traveling in a different country. You can even partner with your friends to share each other’s system.
Please follow the Quick Start Guide to install the server software. The server software installation is the same as desktop (Standard or Professional Edition) software installation.

Please note that the software is exactly the same, regardless of whether it is a shareware, standard, professional, or enterprise edition. The difference is in the license key installed. For example, without an enterprise edition license, all remote access features are disabled.

Once the software is working on the server machine, please setup the gateway password (optional) and area code preferences. Click on the Gateway icon to invoke the gateway main window, select **Setup > Options...** from the main menu, then select the **Control** panel.

---

**ACCESS SERVER FROM LAN**

Voicent Gateway (the server) is actually the software that makes telephone calls. All Voicent applications, such BroadcastByPhone, AutoReminder, and BroadcastByPhone are clients of the gateway. To make a call, they simply submit a call request to the gateway, and query the gateway for call status after the call is made. Technically, the communication protocol between the client and the gateway is HTTP, the same protocol used by the Internet.

Voicent Gateway is listening on port **8155**.

To make sure you can access the server (Voicent Gateway), you should use a regular browser to test it first. You can test it on the same computer. Please type in the following in the browser address bar:

**http://localhost:8155/appclient.jsp?action=ping**

The server should return [OK] as shown below.
If testing from a computer on the same local area network (LAN), replace the word “localhost” to the server computer name or its IP address. You can find the host name and IP address from the gateway main window.

If you see failure on the return, please make sure the gateway is started.

The next most likely cause is your anti-virus or firewall software. They might block Voicent Gateway from listening on the port 8155.

Windows XP and later operating systems provide a built-in firewall. Please make sure accessing Voicent Gateway is enabled. From Windows Control Panel, you can access Windows firewall, click on the Advanced tab, then choose Local Area Connection, click on the Settings... button, then click the Add... button. Enter the service settings, and then click OK.

Your computer might also have other anti-virus or firewall software installed. Please check the vendor’s manual (Norton, McAfee, etc). One way to test it out is to disable or uninstall these software, then install these software back when everything works. You can also take a look at Help > Troubleshooting... from the program main menu, then take a look at the topic labeled “Cannot connect to Voicent Gateway”.

![Service Settings dialog box](image)
Access Server from the Internet

It is a little bit complicated to access Voicent server software from the Internet. Most large organizations set up sophisticated firewall system for security reasons. You should contact your IT organization for allowing access from outside. Basically you need to have your IT organization to allow access the required port on your server machine.

Voicent Gateway uses port 8155. For AgentDialer, the gateway uses an additional port 8165 for remote agent login. For AutoReminder, it uses the port number you set from View > Setup Client Server... dialog window.

To setup remote access from the Internet usually involves configuring your firewall hardware or software. It does not involve configuring Voicent software at all. Voicent could not and will not provide support regarding issues related to your ISP or hardware providers. Please contact your ISP or your router/firewall provider for these issues. Another place to get help is your local computer service companies that provide onsite service.

The following material is provided only as a general guide for setting up remote access and configuring your firewall. It provides some basic information, more related to home networking or small office networking. You can search the Internet for more information.

**Computer IP address**

The IP address is an address that uniquely identifies a computer on a computer network. The format of an IP address is a 32-bit numeric address written as four numbers separated by periods. Each number can be zero to 255. For example, 192.168.0.100 could be an IP address. The main window of Voicent Gateway shows the server computer name and its IP address.

**Static IP address and dynamic IP address**

Your ISP assigns an IP address to your computer when it connects to the network. If your ISP always assigns the same IP address, then you have a static IP address. If your computer IP address changes every time you connect, you have a dynamic IP address. It is much easier to have a static IP address for remote access. Please contact your ISP for static IP service.

**Router**

A router is a device that connects and forwards data among computer networks. Your broadband access device, such as DSL modem or cable modem, usually comes with a built-in router and firewall. Your home network connects to the Internet through that router device.
A router normally contains two IP addresses, one for the outside network and one for the inside network. The outside IP address is usually called Internet or WAN address, and inside address LAN address. Internet address is usually assigned to you by your ISP and LAN address by the router.

**Firewall**

A firewall is a device used to prevent unauthorized access to or from a private network. Firewalls can be implemented in both hardware and software, or a combination of both. The following is a typical home networking connection diagram.

![Home Networking Connection Diagram](image)

To allow remote access from the Internet, you normally have to configure your router/firewall to enable it. Most firewalls block all access from the Internet by default. The following example is for a Linksys router/firewall.

The example assumes that Voicent Gateway is running on a server with IP address 192.168.15.10, and the Internet address for the router is 64.233.187.99.

**Linksys Example**

1. Login to Linksys router/firewall administration home page. Please check your Linksys User Manual for how to do this. Please also note that your Linksys administration page might be different.

2. You can discover your Internet IP address by selecting **Status > Router**. In our example, 64.233.187.99 should be listed. Write down the IP address as you’ll need it for remote access.

3. Click on Applications/Gaming on the top, and then select Port Range Forwarding. In the diagram below, the application name is Gateway, the port is 8155 and 8165, and protocol is TCP, and the server that is running Voicent Gateway has an IP address of 192.168.0.10. Click the Save Settings button.
What this configuration tells the router to do is the following: when a remote computer tries to access the gateway on port 8155 or 8165, the router should forward the request to computer with the IP address 192.168.15.10. The remote computer cannot directly access the gateway computer directly through 192.168.15.10, it is a local address only known to the router. The remote computer must use the Internet/WAN address.

You can test the settings from a remote computer by typing in the following in the browser address bar. Please replace the IP address 64.233.187.99 with your actual Internet IP address.

**http://64.233.187.99:8155/appclient.jsp?action=ping**

You should see [OK] in the browser window if your setting is working.

If not, please check your router/firewall manual or contact your ISP or router/firewall company for help. Voicent support will not know what specific configurations are required for your particular setup environment.
INSTALL AND SETUP CLIENT

To install the client software, start running the installation software you downloaded or on a CD. Click the Enterprise Edition Client Applications button, and then follow the on screen instructions.

Installing the client software is exactly the same as installing the server software, except it is not required to install Voicent Gateway. The software is exactly the same.

If you want to install Voicent Gateway on the machine also, go ahead with the regular installation.

Voicent Gateway requires at least one voice modem on the computer. If you do not have a modem on your computer, please install the applications only, since the gateway software will not run.

The follow sections shows setup steps specific to a product.

BROADCASTBYPHONE ENTERPRISE EDITION

The overview section has a typical setting for BroadcastByPhone enterprise edition.

Setup Server

Voicent Gateway server set up is described in previous sections.

Setup Client

To access a remote Voicent Gateway, select Broadcast > Broadcast Hosts... from the program main menu. Click Add button to add a new host.

As we describe before, Voicent Gateway is listening on port 8155. If you try to access a remote gateway from the Internet, you must configure the router/firewall on the gateway location to allow port 8155 access. Please refer to previous section for details.
AutoReminder program is a client of Voicent Gateway for making phone calls. However, the program is itself a server for other AutoReminder programs. This is because all appointment information is managed by AutoReminder, not the gateway. In order to share appointment information among several AutoReminder programs, one program must be served as a server. The following is a typical setting.

**AutoReminder Enterprise Edition**

Appointment information are kept on server
AutoReminder client does not connect to the gateway directly. It only connects to the AutoReminder server, which must connect to a locally run Voicent Gateway. Any change on the client will be reflected on the server and vice versa.

**Setup Server**

Select **View > Setup Client Server**... from the main menu; then select **Run on Computer where Voicent Gateway is installed**. Also select **Allow web access and Remote Client Access**. Choose a listening port number and access password.

If you need to enable remote access form the Internet, you need to configure your router/firewall to allow access to the port number you specified. There is no need to open the Gateway port (8155 and 8165).

**Setup Client**

You can first test whether you can access the AutoReminder server using a web browser. Simply type in the following in your browser address bar:

```
http://server_hostname_or_ipaddress:port_number
```

Please replace `server_hostname_or_ipaddress` with the real name, and `port_number` with the one you set as Listening port on the server.

To setup the client, select **View > Setup Client Server**... from the program main menu, choose **Run as remote client**, then specify the server name or IP address, the listening port the server is listening, and the server access password. Click OK. Now you should be able to connect to the server next time you run AutoReminder.

If it does not work, please make sure AutoReminder Server is currently running. If it is running, then try to access it from the same machine using a web browse. Try it with the same address listed above. Replace `server_hostname_or_ipaddress` with localhost. If you can access it from a web browser from a local machine but not on a remote machine, you have to take a look at your router/firewall settings. Please refer to the previous sections for details.
Test Client Server Settings

You can add an appointment from the client program; you should see the appointment is added to both the client AutoReminder and server AutoReminder.

AGENT DIALER ENTERPRISE EDITION


When an agent is working on a computer other than the computer Voicent Gateway is running, he or she must login to the gateway using Voicent RemoteAgent program; and he or she must be able to access the same telephone lines Voicent Gateway is using to make phone calls. When a call is answered by a live human, an alert window will pop up on the agent’s computer, it will also play a telephone ring sound over the computer speaker. The alert window will display the gateway host name and the line number, it will also display the current call information, such as the callee’s name and phone number.

The following diagram illustrates a typical setup for a remote agent.

<table>
<thead>
<tr>
<th>Setup RemoteAgent</th>
</tr>
</thead>
<tbody>
<tr>
<td>On each agent’s computer, you have to install Voicent RemoteAgent Program. The program can be installed from the installation package, select</td>
</tr>
</tbody>
</table>
**Enterprise Edition Client Applications** from the dialog window to continue; then choose the RemoteAgent program to install.

The RemoteAgent program simply allows an agent to logon and logoff one or more Voicent Gateway programs. Once it is logged in, the agent computer will receive live human pickup alert popup windows.

Click on the button labeled Hosts... to add, remove, and connect to Voicent Gateways. The gateway listens on port 8155 for the initial connection, and listens on port 8165 for agent login, logout, and alert.

Most likely the connection to the gateway is on the same LAN, because Agent station has to have physical telephone lines that are the same ones used by the gateway. But if for any reason this is not the case, simply follow the instructions listed in previous sections.

**Setup AgentDialer Client**

Same as BroadcastByPhone, AgentDialer can be run from a remote computer other than the one Voicent Gateway is on. It is also possible to use multiple gateways, just as BroadcastByPhone does. To add, remove, and connect to remote gateways, please select **Predictive > Dialing Hosts...** from the main menu, then choose the appropriate buttons.

Please refer to BroadcastByPhone section for more details.

---

**USEFUL RESOURCES**

More information can be accessed from Voicent’s website.

For more product info: [http://www.voicent.com/support](http://www.voicent.com/support).
For developer info: [http://www.voicent.com/devnet](http://www.voicent.com/devnet)

**Copyright:**

This document contains proprietary information protected by copyright, and this Enterprise Edition Setup Guide and all the accompanying hardware, software, and documentation are copyrighted. Copyrighted 2003, 2004, 2005, 2006. Voicent Communications, Inc. All rights reserved.